DNN6 Form Error

Aug 6, 2011 at 7:22 PM

Is it a known issue that the form doesn't work with DNN6?

Tried creating a simple form and each time i get the following error:

UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

DefaultDataProvider: DotNetNuke.Data.SqlDataProvider, DotNetNuke.SqlDataProvider

ExceptionGUID: c1d60578-c05b-4b26-abdc-1300a35f9cd0

InnerException: Object reference not set to an instance of an object.

FileName:

FileLineNumber: 0

FileColumnNumber: 0

Method: helferlein.DNN.Modules.Form.UI.Form.CreateFormItemLabel

StackTrace:

Message: DotNetNuke.Services.Exceptions.PageLoadException: Object reference not set to an instance of an object. ---> System.NullReferenceException: Object reference not set to an instance of an object. at helferlein.DNN.Modules.Form.UI.Form.CreateFormItemLabel(FormItemInfo formItem, Boolean includeRequiredImage, Boolean displayLabelText) at helferlein.DNN.Modules.Form.UI.Form.CreateItem(FormItemInfo formItem) at helferlein.DNN.Modules.Form.UI.Form.Page_Load(Object sender, EventArgs e) at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) --- End of inner exception stack trace ---

 

Thanks for any help/suggestions!

Aug 6, 2011 at 7:46 PM

Never mind! Works great on DNN6! I didn't have the form setup properly.

Another ID10T error between the keyboard and chair ;) Seems I've been pulling too many all-nighters.

Aug 6, 2011 at 8:17 PM
Edited Aug 6, 2011 at 8:30 PM

Ok maybe I spoke a bit too soon... seems I'm getting the error when adding the [LABEL] token to the Form Appearance settings.

Using your examples (both table and table-less) the error persists.

Also when trying to override the form layout within each item results in all html special characters being encoded so <label>XXX</label> becomes &lt;label&gt;XXX&lt;/label&gt;

To work around this for now, I'm editing directly in the database, but that will get overwritten as soon as someone decides to update the item from the portal.

Thanks for your help.

Coordinator
Aug 7, 2011 at 11:40 AM

nxtjv,

I am sorry, but there seems to be a breaking change in DNN6 that produces this error. I am working to find this out, and try to fix it. Anyway, using DNN 6.0.0 in a production environment is quite courageous... ;-)

Best wishes
Michael

Aug 7, 2011 at 2:47 PM
Edited Aug 8, 2011 at 3:51 AM

Hi Maikl ,

Thanks for the reply!

I’m just testing locally… But besides the quirky new UI I’ve found it (DNN6) to run without issue… so far.

Coordinator
Sep 11, 2011 at 12:50 PM

This is fixed in version 02.02.03.

Thank you for your support!

Best wishes
Michael

Sep 11, 2011 at 6:04 PM

Thanks Michael,

I'll test it out today.

Cheers,
Jon