Submissions showing up in a search

Oct 12, 2012 at 2:32 AM
Edited Oct 12, 2012 at 2:47 AM

I have form submissions showing up in a search by other users on the site. I have gone through to each form and unticked "save submission in database" but how do I prevent ones that have already been saved there showing up?

If I now go into the edit submissions area and delete any submissions, does this remove them all from the databse? They will have got the submissions via email because that has always been ticked.

Thanks

Nat

Oct 14, 2012 at 11:39 PM

Hi,

Just chasing this up as it is becoming a breach of confidentiality issue for us now. The box is unticked "save submission in database" and I have deleted all submissions from the database in the edit submissions area of the online form, but they are all still coming up in a search. I would have thought that deleting them would leave no record on there at all?  Where are they being stored to be able to come up in a public search?

Nat

Coordinator
Oct 15, 2012 at 5:09 PM

You also have to delete the search entries in the DNN Search Service tables. For detailed informations, please look at this page.

Best wishes
Michael

Coordinator
Oct 17, 2012 at 5:48 AM

This will be corrected in the next version by not indexing submissions when "Show approved submissions" is set to "Not at all".

Anyway, only approved submissions will be indexed in the search index, so if you do not display the submissions from the database, you will also have to turn off "Auto approve submissions". (This is the way it has always worked).

Best wishes
Michael

Oct 17, 2012 at 8:41 PM
THANKS SO MUCH FOR YOUR HELP, IT ALL SEEMS TO HAVE WORKED.

HAVE A GREAT DAY

Thank you

Nat

On 17/10/2012, at 3:48 PM, Maikl <notifications@codeplex.com> wrote:

From: Maikl

This will be corrected in the next version by not indexing submissions when "Show approved submissions" is set to "Not at all".

Anyway, only approved submissions will be indexed in the search index, so if you do not display the submissions from the database, you will also have to turn off "Auto approve submissions". (This is the way it has always worked).

Best wishes
Michael


Coordinator
Nov 7, 2012 at 11:50 AM

Nat,

the behaviour has been changed in version 02.03.05, so the submissions must also be displayed above or below the form to be included in the search results (beside the fact that they have to be apporved and current).

Best wishes
Michael