Jul 21, 2014 at 1:49 PM
hi there - can you please help with this.

i have the form (installed few days ago), up and running... all ok, then suddenly 2 hours ago it just stop working with the message "Error when sending the email. Please try again later."

i have checked smtp's with hosting provider triple check everything (to underline, in last few days nothing has been done on the form, or the site itself) - so, the hosting provider's support saying "it's something wrong with the form"...

does anyone had experience ever something like this?

(FYI, i am using the form for years now on few dozens sites and never had any problems - the form is superb = so what is the problem now... how is this possible - or should i blame it on gremlins)

thank you for any advise.
Jul 21, 2014 at 1:51 PM
btw - the patch has been applied as discussed somewhere here - as i have said - the form was working just fine.
Jul 21, 2014 at 4:18 PM
this is the error:

UserAgent:Mozilla/5.0 (Windows NT 6.0; rv:30.0) Gecko/20100101 Firefox/30.0
DefaultDataProvider:DotNetNuke.Data.SqlDataProvider, DotNetNuke
InnerException:Mailbox unavailable. The server response was: No such user here
System.Net.Mail.SmtpFailedRecipientException: Mailbox unavailable. The server response was: < > No such user here
at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, Boolean allowUnicode, SmtpFailedRecipientException& exception)
at System.Net.Mail.SmtpClient.Send(MailMessage message)
at DotNetNuke.Services.Mail.Mail.SendMailInternal(MailMessage mailMessage, String subject, String body, MailPriority priority, MailFormat bodyFormat, Encoding bodyEncoding, IEnumerable`1 attachments, String smtpServer, String smtpAuthentication, String smtpUsername, String smtpPassword, Boolean smtpEnableSSL)
Server Name: GENERICUK017

FYI: the module has been reinstalled and patch reapplied - the error is the same???

after days of form working fine - what is happening that this error appear suddenly - don't understand it at all. does anyone have any idea?

thank you
Jul 22, 2014 at 7:31 AM
"The server response was: < > No such user here"

This is the response from the SMTP server. I had a similar problem a few weeks ago, at the end it turned out that there was something wrong with the setup of the sender/recipients account, as this was not a user of the receiving SMTP server. (BTW: The SMTP test in the host settings worked fine, but no module used, neither helferlein_Form, nor DNN Feedback, nor NB_Store, could send an email.)

Please try the following:

Create a page and add a DNN Feedback module. In the module settings use the same recipient and sender as in the helferlein_Form module. Does this work?

If no: please double-check what happens when the mail arrives at the SMTP server. Why is it refusing the mail? (Spam settings, unattended mailbox such as "noreply" etc.)

Best wishes
Jul 22, 2014 at 6:33 PM
Hi Michael,

thank you for your reply.

It was all day that various people try to sort out the error - this is the reply from hosting provider:
Looking over the logs from the relay, it looks like when the form is trying to send, it is failing to authenticate. It appears that the form has not been made compatible with DDN 7.2 and up., Starting in DDN 7.2, DNN started encrypting the STMP password in the database. If a module is using an older method of retrieving the SMTP credentials from DNN, it is not decrypting them before sending the relay. You will need to contact the module developer about this.

There is obviously something wrong - so i will point shortly what is happening:
  • dnn7.2.2; form was installed, patched and was working fine for few days;
  • the receivers email has been changed on form setting - form stopped to work - any attempts so sort out the error don' give a result (btw dnn feedback is working fine).
Michael, if you have any idea how to sort out this - please kindly update me as soon as possible. i have kind of deadline (and in the case that form is not fixed) and i have to find other solution (for this site - as i have mentioned before, the form is up and running on few dozen site without problems).

Thank you once more.

Jul 24, 2014 at 6:39 AM
OK, I'll have a look - hope I can do that over the weekend, but I am quite busy at the moment.

Best wishes
Sep 1, 2014 at 3:51 PM
Edited Sep 1, 2014 at 3:52 PM
I am glad I can offer a solution for that, I fixed it in version 2.3.10 - just need some more small tests if the install/upgrade package works correctly, then you can download the new version. Thanks for your patience.

Best wishes